Can't use my upgrades + Can't get rank points

Tarook Member Posts: 4
edited April 2023 in Bug Report

For some reason at some point all my cosmetics and upgrades were unequipped and I can't put my upgrades back on.

When I go to the shop I do have the 3 biolinks unlocked at level one but only the first one is equipped and when I click on the empty slots I can't put them back on. UPDATE : I have bought two biolinks after that (the faster fire rate and the bigger pickup range). The faster fire rate is equipped (was already) and displays as level two but the other biolinks still aren't equipped.

My level two volt lancer shows up as level 2 in the menus but only has 2 ammo when raiding other people's bases.

When trying to test a level I built with a friend I get 3/2 ammo and then it switches to 3/3 when I shoot->pick up that third ammo.

UPDATE : I raided a base in solo and still had 2/2, I then bought the crossbow and switched weapons a bunch which seems to have fixed it ? (I still get 3/2 ammo sometimes)

I have no way of verifying it but I guess my level 2 fury's edge also gets downgraded to lvl 1.

When I finish a raid I always get 0 rank points.

UPDATE : I have lost 12 points on a raid in which I escaped ??? (I'm bronze 1)

UPDATE 2: I'm pretty sure I get points when raiding solo. I just don't get them/lose some when raiding with a friend (he is hosting).

Basically I'm stuck as a lvl1 Ironside that can't get rank points and there's nothing I can do about it it seems (tried restarting / switching to other character)

UPDATE : Since my Ironside is broken I am now a dual blade wielding Kamaitachi because unlocking upgrades on him seems to work so far.

Post edited by Tarook on
2 votes

Pending · Last Updated


  • Tarook
    Tarook Member Posts: 4

    I will add that I was playing with a friend when all of this happened

  • Tarook
    Tarook Member Posts: 4

    To be more specific it started when we were building a base together. I'm pretty sure it was fine when we were testing the base we built (or I just hadn't noticed) but then we went to raid some other player's bases and I realized that I couldn't use my upgrades and all the ones that aren't equipped by default were unequipped with no way of equipping them again.

    My theory is that since when you build a base with someone you are locked to using what the host owns, this might apply to the raider equipement which would make sense as I have only upgraded my Ironside and he has only upgraded his Kamaitachi so his Ironside is the default lvl 1 one.

  • Fierce_Red_Fox2033
    Fierce_Red_Fox2033 Unconfirmed, Member Posts: 3

    I have the same problem. Seemed to start after I entered a co-op build with a friend.

  • Jackaljax
    Jackaljax Member Posts: 8

    Having a similar issue where my uprgades are not showing on my suit. This seems to have started after playing a session with my friend.

  • ChilliWanilli
    ChilliWanilli Member Posts: 2
    edited April 2023

    Post edited by ChilliWanilli on