Can't use toolbox on generators

Ryder_Moon
Ryder_Moon Member Posts: 1

Hey DBD team! So I play on PS4 and I've been having a problem for awhile now that I can't use toolboxs on generators. I've tried using different toolboxs with add-ons and without add-ons but yet I still can't use it. I'm able to "Repair generator" but it doesn't come up with the option to "Repair with Toolbox". Yet I am able to sabotage hooks with toolboxs which really confused me. It occurs every single game I go in to aswell. If there is any information to help me out with this or if it's a bug it would help alot. Thank you! :)

22
22 votes

Pending · Last Updated

Comments

  • Ink_Eyes
    Ink_Eyes Member Posts: 561

    You probably have the ''use toolbox'' input binded to the same button you use to repair generators normally and that's why you don't get the option, happened to me....

  • FakeGamee96
    FakeGamee96 Member Posts: 10

    I'm also having this problem. On xbox one. My key bindings for item use and gen repair are different but I cannot use the tool box on gens. This happens on all maps. I tested it on mount ormand and yamaoka Estate.

  • dontpanic503
    dontpanic503 Member Posts: 54

    Can confirm this has happened to me too, just started this patch. Was able to sabotage hooks with toolbox but not repair gens with it. Works some games but not others, on variety of maps. Conirmed key bindings for item use & interact are different. Very inconsistent, didn't work one game then worked the next. Playing on Switch.

  • Ladyinadress18
    Ladyinadress18 Member Posts: 243

    I reported this the other day and has still not been acknowledged

  • Kmcauley05
    Kmcauley05 Member Posts: 27

    thank goodness i'm not the only one!! i thought i was going crazy!!

  • Youko
    Youko Member Posts: 187

    This isn't a keybinding problem. I am on default controls on PS4 and this just became a problem for me as well after the last update.

    FYI: You can "fix" your toolbox by setting it down and picking it up again.

    Also would like to add that this occurs for me about 25-50% of the time I bring in any kind of toolbox with or without various addons. Can concur that it is on multiple maps. It also can occur on multiple gens per map (meaning it's toolbox specific, not generator specific).

  • Miss_Johnny
    Miss_Johnny Member Posts: 56
    edited May 2022

    I have the same on PC, noticed it on Lampkin Lane. The option to 'repair with toolbox' is not available. And it's definitely not key-bindings.


  • Nos37
    Nos37 Member Posts: 3,936

    This also happens to me on Xbox with different types of toolboxes across different maps.

    Lately, I have been dropping and picking my toolbox up at the very start of matches.

  • seraphicwolf87
    seraphicwolf87 Member Posts: 6

    I’m on PS4 also having the same issue. It is only a problem if I bring a toolbox into the match. If I find a toolbox in a chest, I can use it. I haven’t tried dropping and picking up a toolbox yet but I’ll definitely give it a go in my next match.

  • Elkhian
    Elkhian Member Posts: 1

    This has happened to me as well, right after the last update. First trial I got in I couldn't use my toolbox on gens. Since then it's been mostly working but here and then i still get this issue and so does my friend (we're both playing on PS4).

  • Marc_123
    Marc_123 Member Posts: 3,210

    Had this too.

    I dropped the toolbox and picked it up again, then it worked again.

  • Nathandrack
    Nathandrack Member Posts: 13

    When are they going to fix it??

  • Ladyinadress18
    Ladyinadress18 Member Posts: 243

    Never. I think so many things in the game are broken right now that they don’t know what to do and have stopped reading bug reports. I reported this a few weeks ago and nothing. So so so many unacknowledged duplicate reports. The last patch a couple days ago didn’t even scrape the surface of the bug reports section.

  • Darthpopper
    Darthpopper Member Posts: 3
    edited May 2022

    Same issue, unable to use toolbox


  • Crazed_rebelchic
    Crazed_rebelchic Member Posts: 13

    Same exact senerio keeps happening to me... This last incident today, I used the "Engineering toolbox" with "brand new part" and an "increased sabotage by 15%", would NOT work in game but was able to sabotage

  • sswhoney1
    sswhoney1 Member Posts: 7

    It's so annoying to be able to use some toolboxes with no add-ons a d then the second you add charges or something toolbox won't work on repairs. DBD needs to fix this. I agree with y'all.

  • foreverno0b
    foreverno0b Member Posts: 8

    I also play on PS4 and have been having the same exact issue. I can’t seem to narrow down if it’s map or add on dependent. Sometimes it happens and sometimes it doesn’t. Hope they fix this soon… 😔

  • Nathandrack
    Nathandrack Member Posts: 13

    They don't care about ps4 version, they will not fix it.