Screen Tearing when playing with V-sync off

Options
Jota
Jota Member Posts: 156

Pls fix this, a lot of people hate having to play with v-sync

2
2 votes

Pending · Last Updated

Comments

  • myers_obsession
    myers_obsession Member Posts: 551
    Options

    Isn't that normal? If you don't want tearing use vsync or monitors with sync options.

  • Jota
    Jota Member Posts: 156
    Options
  • CreepyB4by
    CreepyB4by Member Posts: 13
    Options

    I've been having issues as well. I play on ultra settings and I started having tearing issues. I use V-sync, play at 60fps and I never got frame drops or stuttering, just a few horizontal lines of screen tearing in game. I checked my GPU, it was running at 87%, so I thought maybe that's why. I turned the graphics to low setting and 67% resolution. GPU was at 40%. Still there was screen tearing.


    On top of that, my display is set to 1080p and when I loaded in after the update the resolution was on 4k or something. The in-game FOV was closer than usual and the hud was tiny. I set steam to launch the game at 1080p under launch options and it fixed that problem, but yeah, there are problems since the update. My XB1 has the 4k/1080 resolution problem, too, but there's nothing I can do about it on console.

  • Husk
    Husk Member Posts: 39
    Options

    Yeah I have it too. This game is unplayable with Vsync on because the mouse movement feels so sluggish. I had almost no screen tearing before this patch and a friend of mine has noticed increased screen tearing too. My guess is it's a result of the "updated" graphics.

  • Tatariu
    Tatariu Member Posts: 2,963
    edited September 2020
    Options

    It's because the game now uses true full screen, instead of windowed border-less. Vsync being off, also means that screen tearing will occur. The huge positive to this is that now if you disable Vsync there will be less input lag compared to before. It would be great if this was also an in-game option to adjust :3

  • Jota
    Jota Member Posts: 156
    Options

    I've found a quick fix. If you have NVIDIA GPU just go to Nvidia Panel / 3D Settings, 3D APP settings and choose DBD. Search for Vsync and enable the option named "Fast". It won't limit your fps and it'll fix the screen tearing.

  • Husk
    Husk Member Posts: 39
    Options

    Uhh, not from what I've seen. Where did the devs say the game now uses true fullscreen? Cause from what I've seen, the game still runs borderless fullscreen. Thank you to @Jota for the solution!

  • Tatariu
    Tatariu Member Posts: 2,963
    Options

    if you look in the gamesuersettings.ini file, it should now say full screen mode=0

    if it's not something you like, you can always set those values to 1, or 2 and set the file to read only as a temporary fix.

  • Husk
    Husk Member Posts: 39
    Options

    Yeah, no. The game still isn't running true fullscreen. Either way, if I got the increased tearing without actually being in this proclaimed "true fullscreen", the issue obviously doesn't lie with true fullscreen. Anyway, Jota's solution is working perfectly.

  • RainbowPatooie
    RainbowPatooie Member Posts: 322
    Options

    Seems to work for me as well! It was getting so bad my screen would go black sometimes (and cause me to lose multiple chases). Haven't had this issue since.

  • RainbowPatooie
    RainbowPatooie Member Posts: 322
    Options

    Update: in the latest patch, having sync on eviscerated my frame rate. Turned off vsync in NVIDIA settings and everything's fine now?? No screen tearing and my frame rate is back to normal. I should probably get a new monitor though, mine's several year old.