PC - "Agitated Advantage" and "Buried Underground" challenges not working

littleCT
littleCT Member Posts: 1
edited December 2020 in Bug Reporting

Despite using the Agitation perk and hooking several survivors in the basement, the Agitated Advantage challenge won't be completed in the archives. I've met the requirements for the challenge in two different matches now, but both times the challenge did not get fulfilled for some reason. This has only happened twice so far, but I will continue testing to see if the issue resolves itself.

UPDATE: Upon further playing, I've noticed that the Buried Underground challenge is also no longer working. I have tried multiple times in games where I've done part or all of the challenge, but it has not worked. I have tested this while using both The Trapper and The Pig.

Post edited by littleCT on
22
22 votes

Acknowledged · Last Updated

Comments

  • So_Alba
    So_Alba Member Posts: 1

    I have just experienced the same thing. Two games where I got 5 hooks in the basement while using agitation and the challenge wasn't completed. The second game I believe I got around 10 hooks in the basement (very domintated trial) but still nothing.

  • Rybe
    Rybe Member Posts: 44

    Same thing just happened to me. Well over 5 hooks using agitation (i think 7 or 8) on the Shape. Did not complete the challenge. Was on steam/PC

    Got de-pipped for my efforts too...

  • wxnickxw
    wxnickxw Member Posts: 742

    Is anything happening on this bug? I'm still having it

  • Weckatron
    Weckatron Member Posts: 2

    I also have this issue, I made a different post about it as I didn't find this one at the time.

  • wxnickxw
    wxnickxw Member Posts: 742

    I'm fairly new here. Are the devs likely to fix this quickly or post about the challenges not working ob that blog thing that starts up at the beginning of a game or is this kind of a waste of time to report?


    I tried asking a mod if I should bother posting some other bugs where you can yet stuck but I'm not going to spend the time and effort to record the places I've found if it's not likely to he addressed. I received no response which isn't leading me to think it's worth reporting

  • Sparrow7409
    Sparrow7409 Member Posts: 2

    Buried Underground on tome 1 broken. Hooked all my survivors at least once down there. Also did agitation a while ago and had the same issue.

    On PC

  • wxnickxw
    wxnickxw Member Posts: 742
    edited January 2021

    I keep checking for some sort of response from either the devs a mod or even community members about if bugs are something that gets fixed around here and if there is any kind of time-frame for when these things are. Has anyone been around here long enough to know when or if things will be fixed. Went to google an old bug found one about the near death experience achievement turns out its still bugged and appears to have been that wasly for over a year. Is that an indicator about the turnaround time or that nothing gets fixed?

  • GustavoSW
    GustavoSW Member Posts: 1

    I believe the problem with the Agitated Advantage challenge is a recent bug because I did it and it worked, but it's been a while. I have the same problem in the buried underground challenge, I already did with the trapper, bubba and nightmare and not complete. I tried to hook the 4 in the same match and it didn't work either.

    PS: Sorry for the bad English, it's translated

  • tophat704
    tophat704 Member Posts: 1

    I have had this issue as well. Only recently started going back to old tomes and I cannot get this to trigger at all in several games I've hooked on survivor twice or 2 survivors once, etc. Not triggering.

  • Eskignax
    Eskignax Member Posts: 2

    Same issue. Tome 1, Level 2, hook a lot of people in my little basement. Playing on PC/Steam. Killer Trapper.

  • QuantomX64
    QuantomX64 Member Posts: 12

    I'm having this problem also, but with Tome 3, page 2. Violent Imperative. Hooking 3 people in the basement with Territorial Imperative. wont work

  • Gavanius
    Gavanius Member Posts: 1

    Tome 1 page 3 Buried Underground for PS5 also a no go, although for whatever reason it DOES count (at least for me anyway) whenever I go to Silent Hill

  • Tragopan
    Tragopan Member Posts: 25

    Can confirm Buried Underground (Tome 1 Level 3) is no longer working.

  • wxnickxw
    wxnickxw Member Posts: 742

    I'm guessing from everyone's lack of response that bugs don't generally get fixed them?

  • Mavros_Aguila
    Mavros_Aguila Member Posts: 3

    I can confirm that completing this challenge on Dead Dawn Saloon map will grant the completion of "Agitated Advantage".

    I have read that it will also work on Midwitch but cant confirm yet.

  • wxnickxw
    wxnickxw Member Posts: 742

    Just did it on saloon it did work. Don't have another noose so can't try monstrous mayham or 6 feet under unfortunately. Doesn't seem like devs likely to fix anytime soon given the community's response I've gotten apparently they don't fix bugs quickly

  • FlamedRunner
    FlamedRunner Member Posts: 2

    I have the same problem with the challenge "Violent imperative".

  • Beranabus
    Beranabus Member Posts: 1

    Tried it on Autohaven Wreckers and Coldwind Farm, it didnt count.

    Burnt an offering for dead dawg and can confirm it worked. Did it on Freddy with tier 3 agitation with full perk loadout and addons!

  • Beastycomplains
    Beastycomplains Member Posts: 7

    Please replace all Buried Underground Challenges so I can move on with my completionist life.

  • wxnickxw
    wxnickxw Member Posts: 742

    I haven't been posting on the community for longer than couple weeks but everywhere seems to indicate they don't actually fix bugs I found one from over year ago still not fixed. I've asked community if I'm wrong but no one has said they actually fix reported bugs. I found an uncleanseabke totem earlier today too doubt they know or care about it

  • Knism
    Knism Member Posts: 13

    I thought I just had a glitch, guess I'm not the only one.

    Trapper, laboratory, 6 hooks and 1 sacrifice. 0/3 progress on Tome III Level 1 😔

  • dam_its_smiget
    dam_its_smiget Member Posts: 3

    I would also like to report that I have this challenge glitched as well. I have done it in multiple games. Please fix as this game is awesome!

  • wxnickxw
    wxnickxw Member Posts: 742

    Don't think they fix glitches some remain open from years ago

  • wxnickxw
    wxnickxw Member Posts: 742

    Found a couple more uncleansable totem locations this weekend, figured I'd report them somewhere they'd be taken seriously. So I wrote a quick note and threw it into the trash figure it'll get a faster response that way

  • FeryGEN
    FeryGEN Member Posts: 627

    I agree, Pls fix it.

  • Rydog
    Rydog Member Posts: 3,275

    People have been reporting this for weeks with no fix. I don't understand how a fix for something like this -- a literally unfinishable challenge that you have to go to extreme effort for -- is not either replaced or fixed within a week of it being reported. A receptive developer, like say Riot Games with League of Legends, would issue a hotfix for something like this within days.

  • wxnickxw
    wxnickxw Member Posts: 742

    Yahhhhhh they have bugs from years ago that haven't been fixed (Near death experience) it doesn't seem like bugs actually get fixed. I've asked a couple of times but so far no one had responded that any bugs get fixed. It's why I haven't bothered with the hassle of reporting uncleansable totems. Sorry to be the bearer of bad news but they just don't seem to care

  • ASpazNamedSteve
    ASpazNamedSteve Member Posts: 1,784

    I really hope the next patch comes with fixes for these. This bug completely halts your Rift challenges progress, until they fix it.

  • wxnickxw
    wxnickxw Member Posts: 742

    Based on other bug I'm aware of you need somewhere between one and three years for a fix. Unless someone in the community is willing to correct me. I haven't been posting more than a couple weeks my estimate is based on old unfixed bugs I've found

  • wojtech
    wojtech Member Posts: 192

    I think it's general basement bug, I was doing the hook survivor during EGC and the basement doesn't count either.

  • theDagGER
    theDagGER Member Posts: 1

    Same here. Got pretty frustrated.

  • wxnickxw
    wxnickxw Member Posts: 742

    Yah and they aren't interested in fixing it any time soon

  • Knism
    Knism Member Posts: 13

    I am happy to report that update 4.5.0 on February 9th has resolved the bug! Time to finish some tomes ~♥