The Engineer's Guild challenge BROKEN

Ouro Member Posts: 34
edited September 2021 in Bug Reporting

Hello everyone, my problem is very simple and I hope there is a fix for this. By the way this is on the PC steam version of the game.

I am trying to complete a challenge and every time I do what the challenge wants, it doesn't count towards completion.

The challenge is called The Engineer's Guild - Repair a total of 6 generator(s) while cooperating with other Survivor(s).

So far what I have tried is exit the game and launch it again, change characters and reselect the challenge.

None of them have worked so far so any advice would be appreciated.

P.S. yes I have completed the generator(s) with the survivor(s), I have also left the generator(s) while only doing 50% of them just incase it doesn't want me to complete them. Neither have worked.

P.S.S. So no matter what tome you are doing, if it has The Engineer's Guild challenge it is broken, it cannot be completed on any character, I have had my friends try it aswell and they aren't able to do it at all.

!~Please developers, it has been 11 days since I reported this and no moderator has even seemed to look at it, can we get some recognition please?~!

Post edited by Ouro on
41 votes

Acknowledged · Last Updated