Please note: Although we may stop by occasionally, this is not a developer Q&A.

Issues with EAC when using Heroic/EGS game version, when the game previously worked. Help?

C96ALia
C96ALia Member Posts: 9

Hello all! If anyone needs them, here's my specs:

OS: Fedora Linux 38 (KDE Plasma) KERNEL: 6.3.8-200.fc38.x86_64 CPU: 11th Gen Intel Core i3-1115G4 @ 3.00GHz GPU: Intel Mesa Intel UHD (TGL GT2) GPU DRIVER: 4.6 Mesa 23.1.2 RAM: 16 GB

I've recently reinstalled Fedora, going from 37 to 38. On my previous installation of Fedora I was able to use the unofficial workaround prominently posted here on the forums;

However after my re-install, and re-downloading the AppImage of Heroic Launcher, the Epic Games version seems to have issues with EAC. I'm repeatedly getting Error Code 1, where EAC falsely thinks I have modified game files; sometimes making mention of the anti-cheat hash catalog not being found, though not always. When changing to using Wine alone, the error changes to one of "The EAC client cannot be instantiated."

When running on just wine alone, the error changed to one of "EAC Client cannot be instantiated".

My troubleshooting steps have gone like this;

  • Restart the game using different versions of proton and Wine. (Wine-GE-latest, Wine-GE-Proton7-41, Proton Experimental, GE-Proton7-49, GE-Proton7-55, two versions of bleeding edge Proton-TKG, Proton 7.0, and Proton 8.0, and just plain wine 8.6 staging.)
  • Restart the Heroic Launcher.
  • Restart the computer and try the above two steps again.
  • Verify game files.
  • Re-install the game entirely.
  • Try deleting all the compat configs for the game and Heroic to rebuild them.
  • Run stress tests using Prime95 on my hardware to check for issues on my end. No errors found.

I'm sort of at a loss, as this previously worked on my Fedora 37 installation I had previously, with whatever Wine-GE version I had installed at the time. And by the reports on ProtonDB, this should theoretically work. If anyone knows how or would be willing to help, it would be appreciated. :)

I hope you all have a good day :)

Answers

  • e1ix
    e1ix Member Posts: 66

    idk if you only have the game on Epic, but the Steam version is currently working for me using Proton 8.0-2, without any changes to config or using the Heroic launcher. (I am currently on Debian 12)

  • bionux
    bionux Member Posts: 3

    but the problem of us is that we want use epic to play dbd

  • C96ALia
    C96ALia Member Posts: 9

    The steam version is indeed functional (personally using GE-Proton7-55.) The Epic version just seems broken on Linux.

  • BoddyBoy
    BoddyBoy Member Posts: 4

    Hello,

    I have the same issue with the Epic Games version of the game.

    My assumption is that the Epic Games and Steam binaries are different and the proton EAC runtime only validates one.

    Before the Steam Deck validation, they mixed the versions and the Epic Games version worked with proton-GE + proton EAC runtime, while the Steam version did not. To get Steam Deck verified, they fixed the EAC runtime to match the Steam version of the game. Since then the Steam version works, but the Epic Games version is no longer recognized by the proton EAC runtime. They don't ship a non-proton, EGS compatible, Linux EAC runtime with the game, as far as I can tell.

    Regards.