Can't apply Chemical Trap

Options
TragicSolitude
TragicSolitude Member, Alpha Surveyor Posts: 6,683

I completed an entire generator, threw down a pallet, and the option to apply Chemical Trap wasn't there. I tried throwing down other pallets. I tried pressing all the different buttons. Nothing happened. I completed more generators. I wasn't able to apply Chemical Trap once all trial.

How am I supposed to complete the "Delaying the Inevitable" Tome challenge if Chemical Trap doesn't work? Isn't the only other option Alan Wake's perk, which won't activate against all the killers who are using Lightborn right now to avoid this exact thing? And it's three times in one match. Who designed this godawful challenge? I have to hope I get a killer whose power does it to themselves, basically, in which case my participation isn't even required so why is it a survivor challenge, then? Make it a killer challenge so I can put on Huntress and be done with it.

The map was Blood Lodge, Autohaven. The killer was Trapper. I was running Chemical Trap, Deja Vu, WoO, and Self Care. My buttons are rebound so I press the square button to vault and R1 to heal, because otherwise I might as well put myself on a hook when I play survivor.

Platform: PS4

1
1 votes

Under Review · Last Updated

Thank you for taking the time to report this issue, we are forwarding this to the team for their review.

Comments

  • Hurglet
    Hurglet Member Posts: 1
    Options

    had the same issue, I also rebound my buttons similarly, (Xbox controller) RB for Vault and X for heal/item pickups. For whatever reason active ability 2, which is the button to activate chemical trap, was bound to the exact same thing as my vault button, causing the prompt to never pop up. Can’t guarantee it’s the same for you but double check that neither active ability buttons are bound to the same button as another interaction.